Installation Page History


Before delving into the installation, please check the hardware and software components list over which we tested openLEON.

You will need to install these softwares on each PC:

Installation on the eNodeB PC

  • Install UHD
  • Install srsLTE

Installation on the Mininet/EPC PC

  • Install Virtual Machine
  • Import the virtual image

Installation on the UE PC

  • Install UHD/bladeRF
  • Install srsLTE

If everything is installed, you can go to the page of execution instructions to run the platform.

UHD

Basic dependencies:

 sudo apt-get -y install git swig cmake doxygen build-essential libboost-all-dev libtool libusb-1.0-0 libusb-1.0-0-dev libudev-dev libncurses5-dev libfftw3-bin libfftw3-dev libfftw3-doc libcppunit-1.13-0v5 libcppunit-dev libcppunit-doc ncurses-bin cpufrequtils python-numpy python-numpy-doc python-numpy-dbg python-scipy python-docutils qt4-bin-dbg qt4-default qt4-doc libqt4-dev libqt4-dev-bin python-qt4 python-qt4-dbg python-qt4-dev python-qt4-doc python-qt4-doc libqwt6abi1 libfftw3-bin libfftw3-dev libfftw3-doc ncurses-bin libncurses5 libncurses5-dev libncurses5-dbg libfontconfig1-dev libxrender-dev libpulse-dev swig g++ automake autoconf libtool python-dev libfftw3-dev libcppunit-dev libboost-all-dev libusb-dev libusb-1.0-0-dev fort77 libsdl1.2-dev python-wxgtk3.0 git-core libqt4-dev python-numpy ccache python-opengl libgsl-dev python-cheetah python-mako python-lxml doxygen qt4-default qt4-dev-tools libusb-1.0-0-dev libqwt5-qt4-dev libqwtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4 cmake git-core wget libxi-dev gtk2-engines-pixbuf r-base-dev python-tk liborc-0.4-0 liborc-0.4-dev libasound2-dev python-gtk2 libzmq-dev libzmq1 python-requests python-sphinx libcomedi-dev python-zmq

Install from the binaries files

sudo add-apt-repository ppa:ettusresearch/uhd
sudo apt-get update
sudo apt-get install libuhd-dev libuhd003 uhd-host

bladeRF

Install from the binaries files

sudo add-apt-repository ppa:bladerf/bladerf
sudo apt-get update
sudo apt-get install bladerf libbladerf-dev bladerf-firmware-fx3 bladerf-fpga-hostedx40 

srsLTE

  • Basic dependencies:
sudo apt-get install build-essential git subversion cmake libboost-system-dev libboost-test-dev libboost-thread-dev libqwt-dev libqt4-dev libfftw3-dev libsctp-dev libconfig-dev libconfig++-dev libmbedtls-dev

Clone and install srsLTE. We tested it using the version 18.3.1, for this reason we encourage you to download this version:

git clone https://github.com/srsLTE/srsLTE.git --branch release_18_03_1 --single-branch
cd srsLTE
mkdir build
cd build
cmake ../
make
make test

If you have compiled everything and all the tests were successfully passed, you will find all the srsLTE executables in srsLTE/build

In addition, it is needed to copy the eNodeB and UE configurations files:

cd ..
cp srsenb/enb.conf.example build/srsenb/src/enb.conf
cp srsenb/rr.conf.example build/srsenb/src/rr.conf
cp srsenb/sib.conf.example build/srsenb/src/sib.conf
cp srsenb/drb.conf.example build/srsenb/src/drb.conf
cp srsue/ue.conf.example build/srsue/src/ue.conf

Last edited by Alejandro Blanco